Chocolate Software Forums

FSHost and FSHostSpy => Networks => Topic started by: eul33t on June 21, 2014, 01:15:59 PM

Title: Direct play error on Windows 2012 R2
Post by: eul33t on June 21, 2014, 01:15:59 PM
Hey, I installed FShost today on my dedicated Windows 2012 R2, this error occurs:
http://i.imgur.com/QOAotHj.png
Dxdiag:
http://i.imgur.com/y6yDj0B.png
The only settings I've changed Is I unchecked "host sessions for fs2002" and changed the default port from 80 to 81 (To stop conflicts with websites we have running on the server)
Firewall Is disabled, opened all neccessary ports
Any help, tips or pointers? I've had this running on a home machine (Windows 7) with 0 problems.
Thanks in advance
Title: Re: Direct play error
Post by: eul33t on June 21, 2014, 04:28:26 PM
Fixed it -- I had to turn on Direct play inside of Windows server's legacy settings. Replying to let any future googlers know
Glhf
Title: Re: Direct play error
Post by: Russell Gilbert on June 23, 2014, 06:33:37 AM
Glad you figured it out!

Would you mind documenting the procedure for exactly how you got it working?

Thanks,
Russell
Title: Re: Direct play error
Post by: Dangerousdave26 on March 09, 2015, 05:54:43 PM
eul33t

Thanks I came here looking for this answer.

For those who follow just enable Direct Play in server roles and features.
Title: Re: Direct play error on Windows 2012 R2
Post by: Russell Gilbert on November 11, 2015, 06:52:20 AM
For anyone still following this topic, I've received this question again from an FSHost user trying to get things to work on Windows Server 2012.

If you could take a moment to explain the exact steps involved with enabling DirectPlay, I'd greatly appreciate it -- and so would the person asking. :-)

Thanks,
Russell
Title: Re: Direct play error on Windows 2012 R2
Post by: mevm on November 12, 2015, 11:26:31 AM
To install DirectPlay from Server Manager

--------------------------------------------------------------------------------

1. From the Server Manager, click the Manage menu and select "Add Roles and Features".

2. In the "Add Roles and Features Wizard" window click "Server Selection" on the left.

3. Then click "Features" on the left.

4. In the Features list, look for DirectPlay and enable it with a check mark, and then confirm installation by clicking Install.

5. At the end of the installation, next to DirectPlay, you will find "(Installed)" written in gray.

6. Close the window and restart the server.
 
7. Start FSHost server and it should work perfectly.

I hope this helps.

Ciao a tutti Max
Title: Re: Direct play error on Windows 2012 R2
Post by: Russell Gilbert on November 12, 2015, 11:41:55 AM
Thanks Max!

I understand your instructions completely, but for some reason, on the Windows Server 2012 machine I'm trying this on, I don't see DirectPlay listed in the Features list. Maybe someone else has an idea why it might not be there.

Anyway, I'll pass this along to the person that was asking. Thanks again!

Russell
Title: Re: Direct play error on Windows 2012 R2
Post by: mevm on November 13, 2015, 04:32:10 PM
Hello Russell
I read that you indicate windows server 2012
while I write the instructions for Windows Server 2012 R2
I do not know if it depends on this or if you simply do not wrote R2
Ciao Max