Chocolate Software Forums

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Strange ERROR message...  (Read 4456 times)

lbmartin

  • Newbie
  • *
  • Offline Offline
  • Posts: 2
Strange ERROR message...
« on: May 26, 2010, 05:00:31 PM »

Hello everybody.

I'm a happy user of FSHost for several years now but, few days ago I have changed my ISP. Now I'm behind a modem-router configuration (Internet connection to cable modem and sharing service with a router)
I have checked all the messages about port forwaring. Everything is open like instructions said. Everything was checked with FSPortTest (test said all those ports are open).
But after all this, I got this strange message starting my FSHost like thousend times before...

"ERROR creating FS2004 and FSX session. Is there another copy of FSHost running on this machine? If so, each copy must use a different port for hosting the 2004 session (23456, 23457, 23458, etc.). See Options / Session to change the 2004 host port. This error can also happen when there's a problem with DirectX on this machine. Please go to the Windows Start button, select Run, type "dxdiag" and click OK. Then change to the Network tab and check for errors in the Notes section at the bottom. If you find errors reported, they can usually be fixed by reinstalling DirectX, which can be downloaded for free from http://www.microsoft.com/directx/"

* I'm running Windows XP SP3, with DirectX updated to last version for my computer (9.0c)
* My router is a Belkin N150 and my cable modem is a Motorola SB4200 SURFboard

Any help would be appreciated guys.

Thanks in advance.

Best regards.

Martin
Logged

lbmartin

  • Newbie
  • *
  • Offline Offline
  • Posts: 2
Re: Strange ERROR message...
« Reply #1 on: May 27, 2010, 02:19:40 PM »

Ok... I was checking into my new router settings and I found that Upnp option was connected as default. This option allow external software to autoconfigurate itself with the router's ports.

Now this option is unchecked in my router and everything is working fine again.

It is not a DirectX problem guys!!! Take care with uninstall DirectX...

Regards.

Martin
Logged
Pages: [1]   Go Up