Chocolate Software Forums

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Cannot connect to the master server  (Read 9948 times)

N83JTH

  • Newbie
  • *
  • Offline Offline
  • Posts: 3
Cannot connect to the master server
« on: July 01, 2010, 12:08:28 AM »

I am pulling my hair out! I have multiple computers and a windows server 2003 enterprise server behind my router. the server is in the DMZ with Sygate personal firewall pro on it. the ip is gafs.hopto.org, which has always worked. the remote port is 81. When I go to gafs.hopto.org:81, I see the remote access page. However, FSHost says it cannot see the remote access page, and cannot connect to the remote server. I have disabled the firewall, AND forwarded all ports to the server (even though it is in the DMZ. Still a nogo.  any suggestions? XML is on, and everything.
Logged

Pro_Avia

  • Junior Member
  • **
  • Offline Offline
  • Posts: 25
    • FreedomAir Virtual Airlines
Re: Cannot connect to the master server
« Reply #1 on: July 01, 2010, 11:11:54 PM »

You may wish to have a look at the following section of the FAQ:
http://www.chocolatesoftware.com/fshost/faq.html#webport
Especially the section about changing the remote access port within FSHost (read the paragraph directly ABOVE "Error Message 2:".

Cheers
Logged

N83JTH

  • Newbie
  • *
  • Offline Offline
  • Posts: 3
Re: Cannot connect to the master server
« Reply #2 on: July 03, 2010, 03:40:50 AM »

My computer is on the DMZ on the router however. The IP is correct, and if I copy and paste the ip and put :81 after in an internet browser, I see the remote access page. Any other ideas?
Logged

Air SeaTac

  • Full Member
  • ***
  • Offline Offline
  • Posts: 96
    • Air SeaTac Virtual
Re: Cannot connect to the master server
« Reply #3 on: July 03, 2010, 08:32:51 AM »

I also run a server that can't register (see below).  The requested web page is viewable from the West Coast USA & the UK and I'm beginning to think that maybe it's a network issue at Chocolate Software since when I first set my server up I would see around 200 servers online, now it's around 100.

Master Server registration aborted. The Master Server attempted to verify your server by requesting a web page from it, but was not able to connect to your IP address (208.116.31.89) on port 82

http://208.116.31.89:82/
Logged

Bob_8712E

  • Full Member
  • ***
  • Offline Offline
  • Posts: 58
  • njhops.com
    • My Flight Sim Servers
Re: Cannot connect to the master server
« Reply #4 on: July 03, 2010, 11:41:20 AM »

Same here. Remote access to all servers is fine. FSHostSpy sees port 80 but not 81,82,83 and 84
I havn't changed any settings in 5 years.
I noticed it after a windows security update so I removed the update but that didn't help.
njhops.com
Logged
Robert A. Holland, "-BobH-", http://www.bobholland.com
http://www.njhops.com
FSHost: njhop.hopto.org

Air SeaTac

  • Full Member
  • ***
  • Offline Offline
  • Posts: 96
    • Air SeaTac Virtual
Re: Cannot connect to the master server
« Reply #5 on: July 03, 2010, 11:46:07 AM »

I'm starting to wonder if Russell's hosts have started blocking anything other than port 80
Logged

Russell Gilbert

  • Administrator
  • Guru
  • *****
  • Offline Offline
  • Posts: 1476
    • FSHost
Re: Cannot connect to the master server
« Reply #6 on: July 03, 2010, 12:32:07 PM »

Yeah, I think there's a problem too.  :(

When I run FSHost on my machine and set the Remote Access port to 80, it registers ok with the Master Server. But it fails on 81.  Actually it seems to fail on any port less than 1024 (which is the usual starting port for non-system programs). So I guess the web hosting company I'm using for chocolatesoftware.com has changed their firewall, and it's blocking outgoing TCP connections on those ports now.

So FSHost seems to be ok with Remote Access port 80, and any port in the range from 1024 to 65535 (the highest numbered port you can use).

When I run FSPortTest, it fails on all ports, including 80, 81, 23456, 6073, and 2300 -- basically it failed on all the ports I tried.  So I assume the web host is now blocking all outgoing UDP connections.

Let me work on it a bit and see if I can either fix it, or move it to another server.  In the meantime, try switching your FSHost to one of the ports mentioned above.  I'll post back here again soon.

Thanks,
Russell
Logged

Air SeaTac

  • Full Member
  • ***
  • Offline Offline
  • Posts: 96
    • Air SeaTac Virtual
Re: Cannot connect to the master server
« Reply #7 on: July 03, 2010, 12:35:27 PM »

Switching ports isn't an option to me, hope you find a solution that allows us to keep the setup we have
Logged

Russell Gilbert

  • Administrator
  • Guru
  • *****
  • Offline Offline
  • Posts: 1476
    • FSHost
Re: Cannot connect to the master server
« Reply #8 on: July 03, 2010, 01:26:50 PM »

Ok, I've moved the Master Server to the following URL:

http://fshost.westcoastatc.com/cgi-bin/fshost_master.cgi

Your FSHost server should switch to it automatically the next time it connects to the Master Server -- which is usually every 5 minutes.  You'll see a message like this in the FSHost log window:

100703 14:08:22  The Master Server URL has been updated to: http://fshost.westcoastatc.com/cgi-bin/fshost_master.cgi

Since FSPortTest is hardcoded to point to the Chocolate Software server, I'll have to release a new version of it, to make it work with the new address.  I'll work on that and get back with you...

Let me know how the Master Server change works for you.

Thanks,
Russell
Logged

Air SeaTac

  • Full Member
  • ***
  • Offline Offline
  • Posts: 96
    • Air SeaTac Virtual
Re: Cannot connect to the master server
« Reply #9 on: July 03, 2010, 01:39:34 PM »

Thought I'd have to restart FSHost to make things happen, but got registered when I manually changed the URL

Good work!!
Logged

N83JTH

  • Newbie
  • *
  • Offline Offline
  • Posts: 3
Re: Cannot connect to the master server
« Reply #10 on: July 03, 2010, 11:54:39 PM »

Got an update - 100704 00:49:24  The Master Server URL has been updated to: http://fshost.westcoastatc.com/cgi-bin/fshost_master.cgi. My old, trusty friend, FSHost, is back up and running! Thank you Russell, for your excellent work, and dedication to the flight sim community! The definition of Flight Sim Community has your name in it! :D
Logged

Collegeroad

  • Newbie
  • *
  • Offline Offline
  • Posts: 3
Re: Cannot connect to the master server
« Reply #11 on: August 06, 2010, 08:36:51 AM »

100806 15:33:25  Started FS2004 and FSX session 'Collegeroad's Server'
100806 15:33:25  Your external IP address is:
100806 15:33:25  View status in a browser at:
100806 15:33:25  The Master Server URL has been updated to: http://fshost.westcoastatc.com/cgi-bin/fshost_master.cgi

I get all that on FSHost which is fine I can connect vis my 192.168...... 23456

all ports are open on router and firewall on XP I am testing port on pc with the FSHost I realise that the details for FSPortTest are wrong but cannot understand why people cannot connect as I'm listed on FSHost Spy.


Any Ideas
PS Route is as Bekin and I'm on O2
Logged
Pages: [1]   Go Up
 

anything