Chocolate Software Forums

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: FSHost on Windows 10  (Read 114 times)

Kenny Fox

  • Junior Member
  • **
  • Offline Offline
  • Posts: 21
  • kenny@fsvintageair.com
    • FSVintageAIR
FSHost on Windows 10
« on: February 08, 2020, 06:17:16 PM »

Hello.

I had to upgrade my server PC from windows 7  :'( to windows 10 home. I have made sure that all of the proper ports are open in the router and on windows firewall. It's got to be a windows 10 thing, but in FS2004 I have to click the "Search" button forever to find my FSHost session.  I have tried different client port 23456-23459 on FS2004, but it doesn't seem to help.

FSHostClient for FSX and P3D finds the FSHost server right away.

I'm running FSHost on port 84 because I'm also running Windows Webserver which uses port 80 for my joinFS map. Please need input.

Thank you,
FSV1142 Kenny
« Last Edit: February 11, 2020, 06:30:31 AM by Russell Gilbert »
Logged
Thank you
Kenny
kenny@fsvintageair.com

Russell Gilbert

  • Administrator
  • Guru
  • *****
  • Offline Offline
  • Posts: 1465
    • FSHost
Re: FSHost on Windows 10
« Reply #1 on: February 11, 2020, 07:23:37 AM »

Hi Kenny,

It's best to leave the "FS2004/FSX host port" in FSHost set to the default port 23456. Then in your FS2004, click "Multiplayer" on the FS2004 startup screen, then click "Open Multiplayer Session", then on the screen where you type in the IP address, click "Client Settings", and set the "Connect" port to be 23455. Only you need to do this, so anyone else connecting to your session can leave it on the default port 23456 in their FS2004.

Also, the web port 84 you're using in FSHost is fine - that won't affect this.

Some questions:

1) I assume you're running FSHost and FS2004 on the same machine, right?

2) When you click Search in FS2004 to find FSHost, are you entering anything for the IP address, or leaving it blank?

3) Does it eventually find your FSHost session?

Thanks,
Russell
Logged

Kenny Fox

  • Junior Member
  • **
  • Offline Offline
  • Posts: 21
  • kenny@fsvintageair.com
    • FSVintageAIR
Re: FSHost on Windows 10
« Reply #2 on: February 12, 2020, 04:52:36 PM »

Hello Russell and thank you for the reply.

1. FSHost is on a different PC and a different internet provider from my flight PC.
2. I've used the IP and this address fsv.hopto.org that masks my IP.
3. Flight Sim does eventually find FSHost.

I am running FSHost on Windows 10 home  :-[ I've made sure the ports are forwarded through the router, firewall and antivirus.   

Also I'm running Windows Webserver wich uses port 80 that's why FSHost is on port 84.
Logged
Thank you
Kenny
kenny@fsvintageair.com

Russell Gilbert

  • Administrator
  • Guru
  • *****
  • Offline Offline
  • Posts: 1465
    • FSHost
Re: FSHost on Windows 10
« Reply #3 on: February 13, 2020, 09:13:47 AM »

Ohh - I assumed you were running FSHost on the same machine as FS2004. Ok, you can skip the part about changing FS2004's connect port to 23455 - just leave it on the default 23456. That's only necessary when both programs are on the same PC.

Have you tried running my FSPortTest program on both the FS2004 PC and the FSHost PC, just to make sure there aren't any firewall problems?

Thanks,
Russell
Logged
Pages: [1]   Go Up
 

anything