DirectPlay Windows Server 2019 (x64) - Solved

Started by NET247, May 17, 2021, 05:02:04 AM

Previous topic - Next topic


Recently I had to upgrade my server to Windows Server 2019 Std Edition.

This has brought about a problem with the lack of Direct Play support.

Is there any known work around to allow running FSHost on Server 2019?

Russell Gilbert


I'm not really sure but my understanding is that although DirectPlay is deprecated for new development, it'll still be supported by all versions of DirectX in the future. When I run "dxdiag" on my Windows 10 PC it shows I have DirectX 12 installed, which I believe is the latest. Even though there's no "DirectPlay" tab in dxdiag like there used to be back in DirectX 9, it still works on my PC because the DirectPlay DLLs are included somewhere.

In Windows 10, you can go to Control Panel / "Programs and Features" / "Turn Windows features on or off", and enable "Legacy Components" / "DirectPlay". I have access to a machine running Windows Server 2012 (but not 2019) and when I go to the same window there, it opens "Server Manager" / "Manage" / "Add Roles and Features". There's actually no listing for DirectPlay there but FSHost does run on that machine. When I run dxdiag on that machine it shows that it's running DirectX 11.

Wheat do you see when you run dxdiag?



When ever I try start the multiplayer FS Host server (pressing the Play icon) I get the following in red text:  ERROR creating FS2004 and FSX DirectPlay object

My server has DirectX 12 according to DXDiag and all my other game servers run perfectly fine.

I downloaded an ran FSPortTest which passed on all ports.

Yet when I attempted to run FSHost32 with 2002 & 2004/FSX Options selected or just 2004/FSX selected this was the output.

210518 13:57:09  FSHost 3.2 starting
210518 13:57:09  Loaded text messages
210518 13:57:09  Loaded Chat Commands
210518 13:57:09  Remote Access started
210518 13:57:09  ERROR initializing FS2002 DirectPlay
210518 13:57:09  Version check complete. This is the latest version.
210518 13:57:55  ERROR initializing FS2002 DirectPlay
210518 13:58:04  ERROR creating FS2004 and FSX DirectPlay object

Windows Server 2019 has no Legacy Components, and the Add Roles and Features does not have DirectPlay either.

DX Diag reports the following:

System Information
      Time of this report: 5/18/2021, 14:00:14
      Operating System: Windows Server 2019 Standard 64-bit (10.0, Build 17763) (17763.rs5_release.180914-1434)
      Language: English (Regional Setting: English)
      System Manufacturer: Xen
      System Model: HVM domU
      BIOS: Revision: 1.221  (type: BIOS)
      Processor: Intel(R) Xeon(R) CPU E3-1245 v5 @ 3.50GHz (4 CPUs), ~3.5GHz
      Memory: 4088MB RAM
      Available OS Memory: 4088MB RAM
      Page File: 3045MB used, 1746MB available
      Windows Dir: C:\Windows
      DirectX Version: DirectX 12
      DX Setup Parameters: Not found
      User DPI Setting: 120 DPI (125 percent)
      System DPI Setting: 96 DPI (100 percent)
      DWM DPI Scaling: Disabled
      Miracast: Not Available
      Microsoft Graphics Hybrid: Not Supported
      DxDiag Version: 10.00.17763.0001 64bit Unicode

DxDiag Notes
      Display Tab 1: The file Unknown is not digitally signed, which means that it has not been tested by Microsoft's Windows Hardware Quality Labs (WHQL).  You may be able to get a WHQL logo'd driver from the hardware manufacturer.
      Display Tab 2: Your PC is using the Microsoft Basic Display Adapter. For the best experience, get the latest drivers from Windows Update or from your hardware manufacturer's website. For more information search for 'Microsoft Basic Display Adapter'
        Sound Tab 1: This computer cannot play audio because the Windows Audio service is not enabled.  Use the Sounds and Devices Properties control panel to enable audio. No sound card was found.  If one is expected, you should install a sound driver provided by the hardware manufacturer.
          Input Tab: No problems found.

DirectX Debug Levels
Direct3D:    0/4 (retail)
DirectDraw:  0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay:  0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow:  0/6 (retail)

Russell Gilbert

Your dxdiag info looks similar to what I have on my Windows 10 PC.

I've looked through my code and checked the files on my PC, and I'm sorry to say I don't think I know the answer to this problem. :-( The fact that it can't initialize FS2002 or FS2004 implies that it can't find DirectPlay on your system. I would suggest doing something like trying to install an old version of DirectX but honestly I don't know how to do that or even if it'll work.

Sorry, I wish I could help more! Please let me know if you find the solution.



The problem is there is no DirectPlay available in Windows Server 2019 - I have tried to install older versions of Direct X but with no luck.

It's only frustrating because I've rather enjoyed running a FShost server and tracking flights on it.

If I ever find a work around I'll post it up.


Solution discovered....

So while they have removed it from the GUI you can manually install the feature.

In command prompt (Run as Administrator) issu the following command:

DISM /online /enable-feature /featurename:DirectPlay /all

Russell Gilbert

Hey, that's great!

Glad you found a solution, and thanks for posting it here so other people can find it!