Chocolate Software Forums

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Unable to connect to all players  (Read 8029 times)

Raligard

  • Newbie
  • *
  • Offline Offline
  • Posts: 1
    • Akroma FSHost Server
Unable to connect to all players
« on: January 14, 2004, 06:50:53 PM »

Alright, my friends and I did some fiddling with the FSHost server and individual settings and have found appears to be the problem.

When a player is connecting to my FSHost server through a router it prevents any further players from logging on to it. If players are in before the player with the router signs in they have no prblem remaining in the session, however further attempts to connect by other players afterwards result in the message 'Could not connect to all players' or something along those lines.

Any suggestions on resolving this issue? And if not any hopes it can somehow be bypassed? Thank you all in advance.
« Last Edit: January 14, 2004, 07:40:48 PM by russell »
Logged
~ Raligard

Russell Gilbert

  • Administrator
  • Guru
  • *****
  • Offline Offline
  • Posts: 1476
    • FSHost
Re: Unable to connect to all players
« Reply #1 on: January 14, 2004, 07:40:37 PM »

Hi,

I've seen this asked a lot lately, so I've added some info to the FAQ page -- let me know if you need more info:

What is the error "Unable to connect to all players"?

This error is displayed by FS2004 when trying to connect to a session.  Usually it happens when someone else that's already in the session is using a router and hasn't forwarded the correct ports.  When your FS2004 tries to join, it gets a list of all the players currently in the session and tries to connect to them.  But when it tries to connect to the player with the bad router, it isn't able to communicate with it, so FS2004 aborts the connection (note that FS2002 would happily connect anyway and just not show that player, but FS2004 now uses newer DirectX functions that return an error in this case, so FS2004 actually isn't able to connect this way anymore).  Unfortunately there's not an easy way of figuring out which player is causing the problem, but if you ask everyone if they're using a router, and one of them says they are, and doesn't know about port forwarding, it's a good chance it's him :-)

The person using the router needs to configure it so that certain ports are forwarded to the machine running FS2004.  Typically the port is UDP 23456, but you should ask the person hosting the session if they're using the default hosting ports, or something different.  If things still aren't working, try also forwarding UDP 6073 and the range of UDP 2300 to 2400, since these are the DirectX "alternate" ports, which are sometimes used when the host is using something other than 23456.  Sometimes enabling or disabling UPnP (Universal Plug-n-Play) can help also -- I've received reports from users saying both ways have helped, although I'm not sure why.

See the section "Firewalls, Routers, Ports, and Internet Connection Sharing" on the Help page for more info.

Russell
Logged

SE-75

  • Newbie
  • *
  • Offline Offline
  • Posts: 3
Re: Unable to connect to all players
« Reply #2 on: January 15, 2004, 09:28:58 AM »

UDP 1026 on my router was blocking incoming,
besides other ranges suggested this was the one that solved fshost - routed and non routed fs clients to communicate.

I was looking at firewall log while experimenting

:o
Logged

SE-75

  • Newbie
  • *
  • Offline Offline
  • Posts: 3
Re: Unable to connect to all players
« Reply #3 on: January 19, 2004, 09:45:41 PM »

Btw, I'm not really sure of UDP 1026, we're 6 FS2004 clients connected with no problems and my UDP 1026 is currently blocked.

found info on http://www.flightsim.no/mp/ also

:o
Logged

SE-75

  • Newbie
  • *
  • Offline Offline
  • Posts: 3
Re: Unable to connect to all players
« Reply #4 on: February 01, 2004, 12:37:30 PM »

Actually, It seems to ba a matter of Internet Connection Sharing

http://support.microsoft.com/default.aspx?scid=kb;EN-US;240429

I tried this today with no altered setting on my router firewall. and no problems.
:o
Logged
Pages: [1]   Go Up