Chocolate Software Forums

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Help Please for an Network Idiot  (Read 9758 times)

bushpilot30

  • Newbie
  • *
  • Offline Offline
  • Posts: 7
Help Please for an Network Idiot
« on: March 22, 2004, 01:28:09 PM »

Ok, I admit it - networks and ports etc are one part of computers I haven't figured out  ::)

Have installed Host 3.0 and get the message:

"...attempted to verify your server by requesting a web page from it, but was not able to connect to your IP address (XXX) on port 80. If you have a router or firewall, please change it to allow port 80 to be forwarded to your machine. ..."

Ok, so I 'play' with my router and get the other message -

" other FSHost running or DirectX error"

No other copies are running and DirectX is fine.

So, must be something I'm doing wrong. I've read the forum, Help and Routers sections. I know the port numbers - I don't know what to do with them. Here are the details.

WinXP with firewall running and through a router. One computer only and to be used for FS2004 and FSHost; sometimes together, sometimes not.

Router is Linksys BEFSR41. Would someone take me by the hand and guide me through the not-so-user-friendly pages of the routers interface?

Thanks in advance.
Logged

Aerospace

  • Guest
Re: Help Please for an Network Idiot
« Reply #1 on: March 22, 2004, 02:11:27 PM »

Ok, I'm not sure about the "other FSHost running" error, but as far as port forwarding, it's actually pretty easy (this coming from a network-challenged person myself). Not to insult your intelligence, but I'll just start from the very beginning and assume nothing. If you already know it, then just move on to the next item ;).

First, log onto your Linksys router using your web browser, which I believe defaults to http://192.168.1.1/. If you haven't changed any of the login settings, then leave the Username field blank and type admin (all lower case) as your password. Once you've gained access to the main panel, in the upper right hand corner click on Advanced. At the next menu screen, at the top, second from the left is a button called Forwarding, click on it. Now, fill out the first line of boxes with the following settings (underlined info is what you fill in the boxes):

Customized Applications: FSHost
Ext.Port: 80 To 80
Protocol TCP: checked
Protocol UDP: unchecked
IP Address: 192.168.1.XXX - *Where XXX = the computers IP number that is running FSHost. See below to find out how to determine the computer's IP number
Enable: checked

After you get all that filled out, then hit Apply at the lower left hand portion of the screen and you should be good to go.

*To find your computers IP address, open up an MS-DOS shell window in Windows by going to Start --> Accessories --> Command Prompt (Win2000 or WinXP) or MS-DOS Prompt (WinME). When the shell opens up, regardless of what directory you're in, just type ipconfig. You will be presented with 4 lines of information. The IP Address line is what you want. It will read 192.168.1.XXX. Just transfer the XXX number to the IP Address line in your routers interface to identify that computer for port forwarding.

Well, hopefully that helped. Let me know if you were successful or not.

Jim
Logged

bushpilot30

  • Newbie
  • *
  • Offline Offline
  • Posts: 7
Re: Help Please for an Network Idiot
« Reply #2 on: March 22, 2004, 06:46:04 PM »

Jim ,thanks for the reply and the quick and easy to follow steps - just what I needed...however...still doesn't connect  :-/

Gave me the usual forward port 80 message.

Tried shutting-down WinXP firewall, still didn't work. I have the Webpage / port 80 set in the propeties too btw.

Whats next?

**NEW**
As mentioned I run, or will run, FSHost with FS on one conputer so I'll also have to add the other ports to the 'list', again...how?

Side question to all you network experts - with a router does one really need WinXPs firewall running too?
« Last Edit: March 22, 2004, 07:48:42 PM by bushpilot30 »
Logged

Aerospace

  • Guest
Re: Help Please for an Network Idiot
« Reply #3 on: March 22, 2004, 11:04:05 PM »

I don't mean to be insulting here bushpilot30, so please excuse me if I ask the obvious so that no assumptions are made on anybodies part. Did you restart your computer after you reset the settings in your router? I had to reset my computer because it obtains the IP address dynamically and for some reason, resetting the computer allowed things to flow for me. As far as running FSHost on the same computer as FlightSim, check this out here:
http://www.chocolatesoftware.com/fshost/?faq.html#connect_own_2004

Also, I'll defer your last question to someone far more knowledgable about networks and the like. I'm merely a weekend hack at this stuff :D

Jim
Logged

bushpilot30

  • Newbie
  • *
  • Offline Offline
  • Posts: 7
Re: Help Please for an Network Idiot
« Reply #4 on: March 23, 2004, 12:08:33 AM »

Jim, not a problem. I prefer to go one step at a time - best to assume I know nothing  (at least about this stuff) ;)

As to your question...lets just say that I've rebooted since the settings were made, and I haven't changed them, and it still won't connect.

I can connect FS to MP sessions; FSHost not up or running. I can also connect TeamSpeak and FSHostSpy with no problems .
Logged

Aerospace

  • Guest
Re: Help Please for an Network Idiot
« Reply #5 on: March 23, 2004, 12:39:44 AM »

Ok, for clarification, it seems that you have two issues going.
1) You can't get FSHost to recognize that you've allowed the forwarding of Port 80 through the Linksys switcher.
2) You can't connect FlightSim to FSHost when it's running regardless of the Port 80 issue.

Is that where we stand currently?

Jim
Logged

bushpilot30

  • Newbie
  • *
  • Offline Offline
  • Posts: 7
Re: Help Please for an Network Idiot
« Reply #6 on: March 23, 2004, 12:46:36 AM »

Actually I'm still working on the first problem...haven't even thought about the next step yet but it will be one I need to do yes.

I have read all the Help / FAQ and get that part, it seems to be just getting Linksys and/ or WinXP firewall set to allow connection. (and how to set; beyond what you've already told me - thats done)

Logged

Aerospace

  • Guest
Re: Help Please for an Network Idiot
« Reply #7 on: March 23, 2004, 01:28:37 AM »

Well, my guess is then that it's a WinXP firewall issue. If you setup your router the way I described, then it should work just fine through at least that section. I know as I have the exact same Linksys router that you do. I am, however, running FSHost on a Win2000 machine, so probably your XP firewall is the culprit. Now, I'll have to defer that topic to someone else as I'm absolutely no help when it comes to the whole XP firewall thing, although I do know that it has wreaked havoc on the FlightSim world in general ;)

Jim
Logged

bushpilot30

  • Newbie
  • *
  • Offline Offline
  • Posts: 7
Re: Help Please for an Network Idiot
« Reply #8 on: March 23, 2004, 02:23:22 AM »

Thanks for your efforts Jim.

I've shut-down WinXP firewall and still no go. I was able to connect to my session with FS - blank IP address - but I still get the Port 80 error whenever I try to register.

I've tried the TCP/IP Netbios enable.

Port 80 is forwarded, at least by my undertanding of it (and by following post above)

DirectX Network tested Ok.

Is there perhaps a setting for my (Windows) network that I've missed?



Logged

Aerospace

  • Guest
Re: Help Please for an Network Idiot
« Reply #9 on: March 23, 2004, 04:20:57 AM »

Well, speaking mostly from personal experience and a rapid loss of hair, there is always something that gets missed, usually something as simple as having a space in front of an IP address (yes, this actually happened to me). If you're up for the undertaking, I'd suggest that you reset your Linksys router by pressing in and holding the reset switch for 30 seconds. You'll have to redo everything from the post above, but maybe when you were "playing" with your router, as per your original post, something got checked/unchecked or filled in somewhere that shouldn't be, and it's causing you some headaches.

Might be worth a try...

Jim
Logged

bushpilot30

  • Newbie
  • *
  • Offline Offline
  • Posts: 7
Re: Help Please for an Network Idiot
« Reply #10 on: March 23, 2004, 10:48:25 AM »

LOL - well, that is one I've done too. I even:

Updated the driver, reset the modem and router, reinstalled a Network connection.

Funny, I have complete internet use, have an FTP uploader that uses port 81, can connect (with FSHost at all) to MP sessions - it's just Port 80 (I've also tried ports 80 - 84).

I'm at a loss.

I'm going to try Hosting using FS2004 alone and see if anyone can connect with my public IP - but I doubt it.
Logged

jonf

  • Guru
  • *****
  • Offline Offline
  • Posts: 211
    • Livewire Airlines
Re: Help Please for an Network Idiot
« Reply #11 on: March 23, 2004, 02:23:38 PM »

Many ISPs block port 80 incoming to prevent their subscribers from hosting web sites on their own machines. Try using an unusual port number like 4000.
Logged

bushpilot30

  • Newbie
  • *
  • Offline Offline
  • Posts: 7
Re: Help Please for an Network Idiot
« Reply #12 on: March 23, 2004, 03:31:20 PM »

Heck, I've tried everything else, I'll give that a try - thanks jonf.

**NEW**

Well the port "4000" idea didn't work but it tipped me off to other possiblities beyond the port  "80's" and it worked  ;D

Thanks all for your assist.
« Last Edit: March 23, 2004, 04:02:56 PM by bushpilot30 »
Logged

Aerospace

  • Guest
Re: Help Please for an Network Idiot
« Reply #13 on: March 23, 2004, 09:10:00 PM »

lol, see, there it was, it's the simple things ;)

Congrats on getting your server up and running!

Jim
Logged
Pages: [1]   Go Up
 

anything