Chocolate Software Forums

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: ERROR creating FS2004 session  (Read 5569 times)

jorritvandommelen

  • Newbie
  • *
  • Offline Offline
  • Posts: 4
ERROR creating FS2004 session
« on: April 06, 2004, 08:49:10 AM »

Hi Russel,

I have been running FSHost 3.0 for a while on my PC, but now I have to move it to another PC. I want to move FSHost to the other PC because that other PC can stay on for several days.
While Starting the game server I get an error:

040406 12:20:19  ERROR creating FS2004 session. Is there another copy of FSHost running on this machine? If so, each copy must use a different port for hosting the 2004 session (23456, 23457, 23458, etc.). See Options / Session to change the 2004 host port. This error can also happen when there's a problem with DirectX on this machine. Please go to the Windows Start button, select Run, type "dxdiag" and click OK. Then change to the Network tab and check for errors in the Notes section at the bottom. If you find errors reported, they can usually be fixed by reinstalling DirectX, which can be downloaded for free from http://www.microsoft.com/directx/

I have done everything it says. I update my DirectX to version 9.0B and checked that FSHost was running alone. On the network tab on DxDiag, there are no problems found and the Direct Connect works fine. But the error still appears. It only happens when starting a FS2004 session, the FS2002 session works normal. I have tried to connect the server on different port (23456,23457,23458,80,81,8080) but it make no sense and the error still appears.

(People are able to view the server status via an internet browser.)

My network lay-out:
I have a router with two PC connected to it.
On the PC where FSHost worked before I moved it, is installed Windows XP Home(on this PC FSHost runs normal)
On the PC where I want to get FSHost working, is installed Windows XP Pro. (on this PC I get the error)

The ports FSHost uses are forwarded on my router (23456,23457,80,81,2302-2400,6073) so that could not be the problem.
Also, on the XP Pro PC, there is running IIS.
I thought there maybe was some kind of conflict between IIS and FSHost, but when I turned IIS off, the error still appears.

I have tried almost everything to get FSHost working, but nothing changed. I hope I gave you enough information to solve the problem. I'm looking forward to your reaction. (My ip: 81.204.2.171)

Jorrit


(P.S. Sorry for my English, I'm from the Netherlands)
Logged

jorritvandommelen

  • Newbie
  • *
  • Offline Offline
  • Posts: 4
Re: ERROR creating FS2004 session
« Reply #1 on: April 06, 2004, 08:54:35 AM »

Forgot to say:

XP firewall is off
Logged

jorritvandommelen

  • Newbie
  • *
  • Offline Offline
  • Posts: 4
Re: ERROR creating FS2004 session
« Reply #2 on: April 06, 2004, 10:23:06 AM »

Here I am again,

Sorry I am troublesome, I know, but I have to say something:

Just found out that everything works perfect in windows safe modus with networksupport. So I think something is blocking my FSHost.
I have no idea what it can be. There are no firewalls running on it or something else that can block it. (as far as I know)
I hope you have any idea what it can be, I hope to find out soon.

Bye

Jorrit
Logged

Russell Gilbert

  • Administrator
  • Guru
  • *****
  • Offline Offline
  • Posts: 1476
    • FSHost
Re: ERROR creating FS2004 session
« Reply #3 on: April 21, 2004, 08:06:00 PM »

Hi Jorrit, sorry for the delay.

It sounds like something in the networking part of the PC is blocking the port that DirectPlay is trying to use.  Are there any other network differences between the two PCs?  What network cards do you have in the PC?  I saw a case once where the person had to disable the network card before he was able to host a session with FSHost, because the network card was somehow blocking the port.  I have no idea why, but that's the direction I'd probably look in.

Russell
Logged

jorritvandommelen

  • Newbie
  • *
  • Offline Offline
  • Posts: 4
Re: ERROR creating FS2004 session
« Reply #4 on: April 22, 2004, 10:16:00 AM »

Hi Russel,

Thanks for your reply. The networks cards are not the same in both pc's. In the one where FSHost did work there was a onboard gigabit LAN on my Asus A7V8X mainboard. On the other pc (the one where FSHost does not works) there is a PCI LANCard from Sweex essentials.
The router I have is a E-tech ADSL router.

It looks weird to me to disable the network card, because then I won't have connection, do I? I have looked for programms that could block the port, like virus/firewall software, there is also no visible networkcard programm running.

I don't think there are further differences between the network connections.
I hope the problem can be solved.

Greatings,
Jorrit
Logged
Pages: [1]   Go Up
 

anything