Chocolate Software Forums

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: NetgearDG834G  (Read 6984 times)

mr1964

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
NetgearDG834G
« on: February 27, 2006, 03:54:09 AM »

im having trouble getting FShost3 to register with the master server using port 80,im have 3 computers connected to the router and 1 laptop which is connected wirelessly,i have been through the instructions on how to port forward but with still no success,all the firewalls have been turned off and i have tried using different ports,im tearing my hair out,if anyone has any ideas that i might have missed please let me know as im getting short on hair. :'(
Logged

Russell Gilbert

  • Administrator
  • Guru
  • *****
  • Offline Offline
  • Posts: 1476
    • FSHost
Re: NetgearDG834G
« Reply #1 on: February 27, 2006, 04:51:09 AM »

Some ISPs block port 80 to keep you from running a web server on your machine.  You might try a few other ports, like 81, 82, 1000, etc.  You can change it in the Master Server settings of FSHost.

Russell
Logged

mr1964

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Re: NetgearDG834G
« Reply #2 on: February 27, 2006, 06:01:00 AM »

Thanks for the quick response Russell.but i have tried using different ports in the master server,but it still wont have it,just keep getting the same response,i dont really know what to try. :'(
Logged

Russell Gilbert

  • Administrator
  • Guru
  • *****
  • Offline Offline
  • Posts: 1476
    • FSHost
Re: NetgearDG834G
« Reply #3 on: February 27, 2006, 01:19:38 PM »

Ok, let's go through the port forwarding on your router, to make absolutely sure you didn't miss something.

You said you have a Netgear DG834G.  I've never used that router, but I found some instructions for how to forward ports on that router, so this is how I think it should go...

First, find the "local" IP address on the machine running FSHost.  To do this, on the FSHost PC, go to Start / Programs / Accessories / Command Prompt, type "ipconfig", and press Enter.  You should find an IP address that begins with 192.168.0 (or something close to that).  The last digit is the one you want to remember, and use it in place of the "X" below:

  • Login to the router's config page.
  • Under Security in the left hand menu click Services.
  • Click Add a Custom Service
  • Name: "FSHost-1", Protocol: TCP, Port Start: 81, Port End: 81
  • Apply
  • Under Security in the left hand menu click Rules.
  • Under "Inbound Services" click Add.
  • Service: "FSHost-1", Action: "ALLOW always", Send to LAN Server: 192.168.0.X, Wan users: any, start: (all 0's), end: (all 0's), Log: never
  • Apply

Then set FSHost to use port 81 for the Master Server, and give it a try.  If it doesn't work, let us know all the details of what you tried.  If it does work, you'll probably need to do the same for UDP ports 23456, 6073, and the range from 2300 to 2400.  If you're supporting FS2002, also add TCP 47624.

Russell
Logged

mr1964

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Re: NetgearDG834G
« Reply #4 on: February 27, 2006, 02:49:25 PM »

Hi Russell,ive done exactly what you said and it worked straight away,i also done all the other ports to,know my question is as im on port 81 do i need to tell people that im using that port,or doesnt it matter?
cheers for ya help so far.

Mick ;)
Logged

Russell Gilbert

  • Administrator
  • Guru
  • *****
  • Offline Offline
  • Posts: 1476
    • FSHost
Re: NetgearDG834G
« Reply #5 on: February 27, 2006, 04:03:23 PM »

Yes, if you didn't use the standard port 80, then you'll have to add the port number to your IP address.  For example, if your IP is 123.123.123.123, and you're using port 80, then the address for your public FSHost web page is just:

http://123.123.123.123

But if you used any other port, such as 81, it's like this (note the colon before the port number):

http://123.123.123.123:81
Logged

mr1964

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Re: NetgearDG834G
« Reply #6 on: February 28, 2006, 02:16:33 AM »

Cheers for that russell,your a star,but i have 1 final question hopefully,will people know on fshostspy that im using a different port?if not how will i tell them that im on a diffferent port.thinking about it though ive been on a lot of servers and not changed any settings on PC to join,surely there not all on port 80.what im really saying is that will clients need to change any settings to join my server.

Mick ;D
Logged

Russell Gilbert

  • Administrator
  • Guru
  • *****
  • Offline Offline
  • Posts: 1476
    • FSHost
Re: NetgearDG834G
« Reply #7 on: February 28, 2006, 01:42:37 PM »

The port you changed is only used for "Remote Access" (the FSHost web pages) and the "Master Server" (registering so you appear in FSHostSpy).  But it doesn't have anything to do with connecting Flight Simulator to FSHost -- those ports are UDP 23456, 6073, and 2300-2400 (which you also should be forwarding, if you're not already).  So the only time anyone has to worry about port 81 on your server is when they're looking at your public status web page, and then they'll need to use:

http://172.216.31.94:81/

I can see you're showing up in FSHostSpy just fine, so that's good to see.  When I select your server in the list, I can then click the "FSHost Page" button on the right, and it takes me straight to the URL above -- in other words, FSHostSpy automatically adds the :81 to the end of the URL, since it already knows you're using a different port.  So the only time it'd be a problem for someone is if they were typing in your IP address by hand -- but it's fine if they're using FSHostSpy.

Russell
Logged

mr1964

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Re: NetgearDG834G
« Reply #8 on: March 01, 2006, 04:34:39 AM »

Cheers for all your help Russell its much appreciated ;D

Mick
Logged
Pages: [1]   Go Up