Chocolate Software Forums

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Can't connect to master server  (Read 6144 times)

wheelie

  • Senior Member
  • ****
  • Offline Offline
  • Posts: 111
    • Flightservers.net
Can't connect to master server
« on: March 18, 2007, 02:22:37 PM »

I have FSHost running on a LAN.
- the PC running FSHost has an IP address of 195.168.123.165
- 2 other PC's running on the LAN have IP addresses: 195.168.123.105 and 195.168.123.104. Both of these PCs have no problem connecting to the FSHost session.

The LAN router has an IP address of 195.168.123.254 and this connects to the internet through an ADSL modem (and it is setup to forward port 80 and 23456 to 195.168.123.165)

I have tried many different configurations of portforwarding in the ADSL modem but cannot get connected to the master server (or rather the master server connect to FSHost)

some combinations I have tried are:
- forwarding port 80 to 195.168.123.165 (i.e. to the PC with FSHost)
- forwarding port 80 to 195.168.123.254 (i.e. to the router - hoping it will forward the port to 165)
- forwarding port 80 to 10.0.0.50 (another internal address)
- forwarding port 80 to 10.0.0.138 (another internal address)

I have just spent all day Sunday trying these options, restarting the router, restarting FSHost etc etc (and, before you ask, I have switched all the firewalls off so there should be no problem on that front).

Has anybody any experience in this area that might be able to point me in the right direction to get this connection working?

Wheelie
Logged

Russell Gilbert

  • Administrator
  • Guru
  • *****
  • Offline Offline
  • Posts: 1476
    • FSHost
Re: Can't connect to master server
« Reply #1 on: March 20, 2007, 07:48:17 AM »

Hi Wheelie,

I can see in the Master Server logs that you've tried ports 80, 81, and 800, which is good.  The way to set this up in your router is to forward that port (TCP, if you have a choice in the router, otherwise it'll do TCP and UDP, which is fine also) to the machine running FSHost.  That way, when the Master Server tries to connect back to you (or more importantly, when other players try to connect to your FSHost), it/they will first connect to your router, which will then forward the incoming data to FSHost.  Without that forwarding setup, the router will just "eat" the data and FSHost will never see it.

Try forwarding whichever port you're using to the FSHost PC (195.168.123.165) again and see if you can get it working that way.

Thanks,
Russell
Logged

wheelie

  • Senior Member
  • ****
  • Offline Offline
  • Posts: 111
    • Flightservers.net
Re: Can't connect to master server
« Reply #2 on: March 31, 2007, 03:16:31 PM »

After a lot of deleted expletives I finally managed to make this configuration work. Just in case anybody else has a complicated set-up and can't make it work - this is what works for me:

INTERNET SIDE:
The ADSL modem has an IP address of 10.0.0.138

In the NAPT section I set it up so that incoming ports 81, 82, 83, and 84 from IP address 0.0.0.0 will be forwarded to 10.0.0.50 (i.e. to the Broadband Router).

*** I had mistakenly tried forwarding these ports from external IP address (81.something.something.something) to the PC that was running FSHost (192.168.123.165) on the other side of the broadband router (downstream from the ADSL modem). I had also tried forwarding to the broadband router's external IP address (192.168.123.254) which didn't work either.

BROADBAND ROUTER
In the virtual server part I set it up so that ports 81, 82, 83, and 84 will be forwarded to the PC running FSHost (internal IP address is 192.168.123.165)

This configuration works and I have managed to create four different FSHost sssions all running at the same time on the same PC wihtout having to reconfigure the ADSL modem or the broadband router.



This may seem simple but.....
The instructions on how to set up the ADSL modem indicate that the port forwarding  address should be the IP address of the PC running FSHost. This is not the case. It has to be the internal IP address of the downstream router (i.e. 10.0.0.50 rather than its external addres of 192.168.123.254). The external IP address has to be 0.0.0.0 and not the real external IP address.

The broadband router configuration is pretty simple and just has to forward ports 81, 82, 83, and 84 to the PC running FSHost.

What about the Firewall? I have had the firewall switched off while I have been setting this up (didn't want another barrier in my way at this stage). So I am not sure what I need to do yet to make sure that this will still work with a firewall in place.

Logged
Pages: [1]   Go Up
 

anything