FSHost and FSHostSpy > Networks

FSPortTest (use this tool to check your network)

<< < (2/11) > >>

Russell Gilbert:
Hi guys, thanks for the feedback.

I increased the timeouts a bit to hopefully get rid of a few of the "requesting URL" timeout errors (that's the part where it's asking the server to send back a message to the port) and changed several of the messages to be a bit more helpful, including the "press any key" message, and added new summary messages at the end.

Wheelie: I think it's best not to add any more ports to the default list because they'd just time out and produce errors for most people.  But you can easily add them to your own list using the instructions in my original post.  Or if you find yourself wanting to test your machine on a regular basis, you can create a shortcut to the program that will always test whatever ports you want.  Here's how...  Open an Explorer window to the directory where you saved the program, right-click the file and select Copy, right-click in a blank area of the same directory and select "Paste Shortcut", then right-click on the new shortcut you just made and select Properties, then in the "Target" box, add a space after the program name, followed by all the extra ports you want to test, with a space between each one.  For example, "C:\FSPortTest.exe 23450 23451 23452".  Then you can rename the shortcut to something like "My FSPortTest", and whenever you run it, it'll test the additional ports as well.  Also, you asked about your IP address...  The 10.0.0.50 IP address is a fake one that you normally see only on your local network -- like 192.168.x.x, for example.  I don't know why they're seeing that on the server, but I've seen it happen before, so it's probably nothing to worry about.  FSHost reports your IP address when it first starts up, since you'll need to give it to other people so they can connect to you, but people don't usually need it if they're just connecting to someone else's session.  You can always go to www.whatismyip.com though, if you want to check it.

Thanks guys, and I'm still interested in hearing reports from anyone else that tries it.  I'm thinking that if this continues to be useful, it might be something that could be incorporated into FSHost and FSHostClient so you could run it directly from inside those programs.  Then FS2002 and FS2004 users could still download the separate program to test their networks as well.

Russell

Russell Gilbert:
I've had a couple of emails from people asking why the tests fail on their machine even though FS2004 and/or FSX seem to be working ok.

I've seen that happen before.  What's happening is that FS is connecting to the server on 23456, and since the router sees the connection initially being made from inside your LAN, it allows the connection out and then also automatically forwards data coming back in on that port to the same machine that requested it.  This is why you don't have to forward every port your machine connects out on -- because the router sees the outgoing request and then allows data to come back in on the same port without a forwarding rule.  And you can even have multiple machines going out on the same port, and your router is smart enough to automatically forward the return data back to the right machine.

However, sometimes FS will end up switching off of the 23456 port and onto the "alternate" ports, which are 6073 and a sorta-random port in the 2300-2400 range (typically the lower numbered ports in that range).  It only does it in certain situations, but when it does, data will be coming back into those ports and the router will have never seen any data going out on them, so it won't know how to forward them to the right machine.  So those ports have to be explicitly forwarded to the FS machine.  This can also happen when you have FS and FSHost on the same machine and you're connecting to your own session, because in that case you have to tell FS to use some port other than 23456 (since it's already being used by FSHost), and then FS will switch to the alternate ports.

Back in FS2002, it always used a port in the 2300-2400 range, and it caused lots of problems for people that didn't know how to setup their networks to allow the incoming data on a random port.  So when Microsoft released FS2004, they changed it so it would always try to use one standard port, which was 23456.  But they left the random port stuff in there as well, for the cases where it wasn't able to use 23456.  FSHostClient (for FSX) uses the FS2004 method of connecting to the session, so it behaves the same as FS2004 in that case.

So you can usually get away with just using 23456 with FS2004 and FSX.  But you should be aware that your setup is not optimal (networking-wise, anyway), and there's a slight chance that it could cause problems for other people in the session.  For that reason, it's always best if you can setup your firewall or router to forward the correct ports to the FS machine, and then you'll be sure that everything's ok.

Unfortunately if you have FSHost and FS on different machines in your local network, there's no good way to solve the problem because you can't explicitly forward a port to more than one machine.  If you can run both on the same machine, it's always better because you can forward all the ports to just one machine (and usually FSHost doesn't cause problems for FS).  Otherwise I'd suggest forwarding all the ports to the FSHost machine, and then just rely on port 23456 for the FS machine, since your router will do the automatic routing when it sees the outgoing connection from that machine.

Hope that helps explain it a bit... It's a bit of a mess, this whole thing with how FS uses ports.

Russell

tuscan17:
Hello Russel!

Well... I have been trying to have FSHost running on my XP PC but... can't solve the connection problem to master server.

I have read that XP user should disable the firewall because no solution have been found. So I did but...nothing good.
I still get the error

071201 23:52:50  Master Server registration aborted. The Master Server attempted to verify your server by requesting a web page from it, but was not able to connect to your IP address (81.208.83.216) on port 80. If you have a router or firewall, please change it to allow port 80 to be forwarded to your machine. For help, see the FAQ page under the Help menu. Also, please verify your IP address on the Options / Master Server window. FSHostSpy will not be able to show your server.

I also tried to change the port from 80 to 81 in the FSHost Options/Remote Access  --- useless!

SO I tried to run your network test tool but, all the ports have been reported with an error.

Can u help me?

Monday I'll send you a postcard from Florence (Italy)

Thanks bro!

Russell Gilbert:
Hi tuscan,

Are you using a router?  If so, have you forwarded all the correct ports for FS?

Russell

tuscan17:
Hello!

I found out that the problem is on my ISP (fastweb) side because they assign a shared external IP to many of their users. Also, the router they gave me is not configurable. It'a an italian mafia s***!

Fastweb seems to be the only italian ISP that't using this IP sharing policy to prevent users from sharing files P2P

Gabriele

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version